Known Issues

From WikiWorld

Jump to: navigation, search

Please list known problems with the PhpWiki2MediaWiki conversion below, as well as issues specific to MediaWiki.

Contents

DB oddness?

On the special page, statistics I found the following to be quite odd. Can you guess why?

WikiWorld statistics
There are 2,300 total pages in the database. This includes "talk" pages, pages about WikiWorld, minimal "stub" pages, redirects, and others that probably don't qualify as content pages. Excluding those, there are 18,446,744,073,709,551,610 pages that are probably legitimate content pages.

I think we've started decoding those signals lost in the black holes to have "18,446,744,073,709,551,610 pages", don't you? --StarPilot 16:33, 12 July 2006 (EDT)

  • KenSchry 16:41, 14 July 2006 (EDT): Humm. Honestly, I'm not sure? I'll have to investigate how MediaWiki determines what is a "valid" content page. I don't think that it's an effect of the port because the values on port were: "There are 2,262 total pages in the database. This includes "talk" pages, pages about WikiWorld, minimal "stub" pages, redirects, and others that probably don't qualify as content pages. Excluding those, there are 1 pages that are probably legitimate content pages." However, those values don't make sense either, because there were exactly 900 pages when we ported over. I'll look into it...

Why does Random page often result in "Bad Title" pages?

Any ideas? Often when I click on Random page I get "Bad Title" page. Just how does the Random page pick a title to show? Is it just picking out random WikiWord (wanted or not)? Just curious. ---StarPilot 14:51, 21 July 2006 (EDT)

  • KenSchry 21:04, 3 August 2006 (EDT): Apparently, pages with a title that has a symbol in it, such as a tick, were not ported over in the conversion. The pages were registered, the content was just not ported over. I am manually restoring those pages from eies.net now. However, That does not fix the issue, because MediaWiki appears to be adding characters to the title (for example, trying to load a page with %27 instead of the ' that it should be loading). We may have to edit the database manually to correct this behaviour.

Problems with Link Conversion

This has occured in some, but not all instances.

  • the _ symbol has been converted to '' (That's two tick symbols, not one quote.)
  • the = sign has been converted to <code>

Tasks

[ ] Investigate Wiki statistics problem.
[ ] Import pages with character issues.
[ ] Inspect the database registry to find the cause of character conversion issues.
[ ] Correct links with converted symbols.

Personal tools